Home > Fatal Python > Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew

Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew

Contents

On 10.8, Xcode-only here. Apply the patch then run brew postinstall vtk python -c "import vtk" and see if it fixes the crashes? Already have an account? Once we find the python .so or .dylib modules those formulas create, we can also run a quick otool -L on them to check that they are linking against HB python weblink

Reload to refresh your session. brew rm python brew install py2cairo brew install pygtk which python /usr/bin/python python Python 2.7.2 (default, Jun 20 2012, 16:23:33) [GCC 4.2.1 Compatible Apple Clang 4.0 (tags/Apple/clang-418.0.60)] on darwin Type "help", NxLsRxLcwJIn particular I fixed the problem using:Everything I have read suggests this is due to conflicting python installations. According to @Evert's comments of different libraries used by different python, I tried to revert the python27-apple to be "active". http://stackoverflow.com/questions/15678153/homebrew-python-on-mac-os-x-10-8-fatal-python-error-pythreadstate-get-no-cu

Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew

Part of it could be may fault, because I coded py2cairo to use the first python-config it finds in your path. iMichka commented May 17, 2016 You can git clone the VTK project from my fork, checkout my branch (vtkNoPythonLink), modify your local vtk formula by adding head "/Users/myname/VTK", :using => :git, Abort trap: 6 Scenario 3 (building vtk from source doesn't solve the problem, as cmake picks up system python even when brewed python is available and comes first in PATH): start For your build problem, let's try to get that sorted out here: Make sure my branch is up to date: I ammended the commit I made Do you have brewed python

iMichka commented May 17, 2016 For the record, I started to work on a patch. To update them pip install --upgrade setuptools pip install --upgrade pip You can install Python packages with pip install They will install into the site-package directory /Users/benjamin/homebrew/lib/python2.7/site-packages See: https://github.com/Homebrew/homebrew/wiki/Homebrew-and-Python .app Mein KontoSucheMapsYouTubePlayNewsGmailDriveKalenderGoogle+ÜbersetzerFotosMehrShoppingDocsBooksBloggerKontakteHangoutsNoch mehr von GoogleAnmeldenAusgeblendete FelderNach Gruppen oder Nachrichten suchen Fatal Python Error: Pythreadstate_get: No Current Thread Anaconda Chrismarsh commented May 17, 2016 iMichka, this is good news.

The person reporting the bug can probably work around this problem by setting the environment variable DYLD_LIBRARY_PATH to /opt/local. Or I have to use default python for now. I was using python.exe and >a xxx.pyd. Do you have a minimal code example that produces a crash?

Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. Mayavi Fatal Python Error: Pythreadstate_get: No Current Thread for example: LDFLAGS += -lm -lbz2 -lz -llzma -lsnappy -lmuparser -lpython to LDFLAGS += -lm -lbz2 -lz -llzma -lsnappy -lmuparser -L/usr/local/Cellar/python/2.7.10_2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/config -lpython2.7 -ldl -framework CoreFoundation make clean, then make again Now stefanoborini commented May 3, 2016 @gutia if the system python is the same version, you can just use install_name_tool to change the dependency. Bug reports / build errors: After PR #3313 (see also discussion there), which leads vtk to link to system python when it is available, makes it impossible to have vtk coexist

  • could you try the following: export PATH="/Users/sabae/.homebrew/bin:$PATH" brew test -v pygtk To reset your path variable you should close the terminal window and reopen it again, or type bash -login staticfloat
  • comment:6 Changed 3 years ago by [email protected]… I am guessing that somehow a wrong dynamic library is picked up.
  • puiseux commented Sep 26, 2016 Still crashes : [Lun sep 26][05:05 ]@[TP2] $ brew postinstall vtk [Lun sep 26][05:31 ]@[TP2] $ python -c "import vtk" Fatal Python error: PyThreadState_Get: no current
  • This was referenced Aug 6, 2016 Closed brew install vtk --with-qt5 fails #4021 Open OSX support rustychris/stomel#1 fbender commented Aug 13, 2016 • edited Seems like this is continued in !1713

Fatal Python Error: Pythreadstate_get: No Current Thread Swig

However, your latest patch fixes the compile. page The discussion should continue in #3811. Sign up for free to join this conversation on GitHub. Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew more hot questions question feed lang-py about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Fatal Python Error: Pythreadstate_get: No Current Thread Vim When I open python and run import gtk, python segfaults, and it seems this issue is not new.

I'd say solved. http://bashprofile.net/fatal-python/fatal-python-error-deallocating-none-urlgrabber.html I will test further tomorrow. Thanks! Is the NHS wrong about passwords? Fatal Python Error: Pythreadstate_get: No Current Thread Vtk

I assumed it is fixed now ... So adding this to the path worked for me: export LD_LIBRARY_PATH=/usr/local/Cellar/python/2.7.11/Frameworks/Python.framework/Versions/2.7/lib:$LD_LIBRARY_PATH stefanoborini commented Apr 29, 2016 • edited @gutia I am surprised it did, but I might be wrong. The system framework absolute path is hardcoded in the dylib files, so it will always be resolved to the system framework. check over here Fixes #32180. 73a191f BrewTestBot added a commit to BrewTestBot/homebrew that referenced this issue Sep 9, 2014 tdsmith Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc.

Register Lost Password Login Home News Guide Mailing Lists New Ticket Ticket Reports Ticket Search Ticket Query Projects Apple Lossless Audio Codec Calendar and Contacts Server DarwinBuild Darwin Streaming Server DCERPC Thank you for the patch! If you decided to go this way I would recommend to use http://pypi.python.org/pypi/virtualenv package to maintain different python env. Fatal Python Error Pythreadstate_get No Current Thread Abort -trap comment:16 Changed 3 years ago by [email protected]… All those /usr/local/lib library references in the otool -L output are suspicious, e.g. /usr/local/lib/libboost_iostreams.dylib , /usr/local/lib/libboost_python.dylib, et al.

Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. samueljohn commented Nov 9, 2012 grrr ... Checked that a similar issue hasn't already been filed? http://bashprofile.net/fatal-python/fatal-python-error-interpreter-not-initialized.html The general steps are: Download patch: https://github.com/Homebrew/homebrew-science/pull/4342.patch Apply patch: patch /usr/local/Homebrew/Library/Taps/homebrew/homebrew-science/vtk.rb 4342.patch Install: brew install vtk dmwelch commented Sep 26, 2016 I can confirm the patch.

Going to be away for 4 months, should we turn off the refrigerator or leave it on with water inside? All rights reserved. Replace it by the full path name of each dynamic library in the list (i.e., the names ending in .dylib. I'll cc @tdsmith who might have ideas or suggest potential problems. 👍 1 lantiga commented Mar 17, 2016 @dpo thank you for the feedback dpo added bug python labels Mar

pvtl:~ felix$ brew doctor Warning: /usr/bin occurs before /usr/local/bin This means that system-provided programs will be used instead of those provided by Homebrew. comment:13 Changed 3 years ago by [email protected]… Possibly. Join them; it only takes a minute: Sign up Homebrew + Python on mac os x 10.8: Fatal Python error: PyThreadState_Get: no current thread importing mapnik up vote 24 down vote Already downloaded: /Library/Caches/Homebrew/graphviz-2.38.0.tar.gz ==> Downloading https://trac.macports.org/export/103168/trunk/dports/graphics/gr Already downloaded: /Library/Caches/Homebrew/graphviz--patch-b242fb8fa81489dd16830e5df6bbf5448a3874d5.diff ==> Patching patching file macosx/graphviz.xcodeproj/project.pbxproj ==> ./configure --prefix=/usr/local/Cellar/graphviz/2.38.0 --without-qt --with-q ==> make install 🍺 /usr/local/Cellar/graphviz/2.38.0: 504 files, 69M, built in 54 seconds

Importing gobject works just fine, and I can ^D out of the python interpreter after importing just fine, but importing cairo immediately errors out: $ python Python 2.7.3 (default, Sep 25 Was there any particular reason you downloaded a separate python2.7 version rather than use the default 2.7 installation that comes with Mountain Lion? I did try a clean install of these packages against system python today, and I can import both py2cairo and pygtk. Consider setting the PATH for example like so echo export PATH='/Users/benjamin/homebrew/bin:$PATH' >> ~/.bash_profile (localhost ~)% homebrew/bin/brew install python ==> Installing dependencies for python: pkg-config, readline, sqlite, gdbm, makedepend, openssl ==> Installing

Then you can fix by using install_name_tool. Generally there are no consequences of this for you. The actual patch used here is a slightly modified version as the code had diverged between vtk 7.0.0 and the current HEAD 5c3c418 iMichka added a commit to iMichka/homebrew-science