Home > Fatal Python > Fatal Python Error Interpreter Not Initialized

Fatal Python Error Interpreter Not Initialized

Deinstalled and reinstalled python. for the same error with python. python opencv osx-snow-leopard python-2.7 share|improve this question edited Jan 2 '11 at 17:59 marcog 60k32153187 asked Jan 2 '11 at 17:42 user122299 possible duplicate of Has anyone ever had Can Dandelion defeat you? check over here

dlopen("/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so", 2); import readline # dynamically loaded from /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload/readline.so >>> import cv dlopen("./cv.so", 2); Fatal Python error: Interpreter not initialized (version mismatch?) and then it crashes (core dumps). python -v gives nothing after the dlopen. Do you use a different ruby? I have dumped /usr/local in the trash after uninstalling HomeBrew a least three times in the last three days.

sbfreddie commented Aug 16, 2012 Well it looks like the links are now working. It appears to compile just fine (I'm using the distutils setup.py to compile it), but when I import it in my Python script, it says "Fatal Error: Interpreter not initialized (version When I look in /usr/local/bin for the symlinks to python they appear to be there but when you ask for the finder to "Show Original" it comes up with nothing! What's going wrong here?

  1. Mixing those is probably your problem.
  2. You signed out in another tab or window.
  3. Mein KontoSucheMapsYouTubePlayNewsGmailDriveKalenderGoogle+ÜbersetzerFotosMehrShoppingDocsBooksBloggerKontakteHangoutsNoch mehr von GoogleAnmeldenAusgeblendete FelderNach Gruppen oder Nachrichten suchen Reinout van Rees Weblog Preken (NL) Over mij (NL) About me (EN) Ligfiets (NL) AEC research (EN) You are here: Home
  4. XL64 commented Mar 12, 2013 Hello, I untapped the phinze/homebrew-cask and removed all link it created in /formula repertory (doctor was still complaining) Now, my doctor is fine with my installation.
  5. the one which pops up when running ``python``) instead of the requested one.
  6. I wrote an extension module, in C, and got it to compile and run just fine, in MacOSX 10.2, using the MacPython 2.3 package that I downloaded.
  7. need book id, written before 1996, it's about a teleport company that sends students learning to become colonists to another world Is there any job that can't be automated?

Thanks, Freddie Owner titanous commented Aug 16, 2012 Dumb question: have you reloaded your shell since fixing the symlinks? Isn't that more expensive than an elevated system? Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. sbfreddie commented Aug 16, 2012 Jonathan: The output of which python is: /usr/bin/python The output of python --version is: Python 2.7.1 Here is the output of env: TERM_PROGRAM=Apple_Terminal SHELL=/bin/bash TERM=xterm-256color TMPDIR=/var/folders/rb/y3bt7gq151x05xlwpzpzc0hm0000gt/T/

from gnuradio.grc.python.Platform import Platform Fatal Python error: Interpreter not initialized (version mismatch?) Any suggestions on where I could go from here? Sign up for free to join this conversation on problem with embbed boost.python in multi-interpreter andmulti-thread HELP please Python 2.3 problem with extention-embedding in multi-threaded andmulti sub-interpreter environment static program including python interpreter + dynamic python extensions Fatal Python error: He has been having similar problems with the Mountain Lion install also. https://github.com/Homebrew/legacy-homebrew/issues/18319 Owner titanous commented Aug 17, 2012 Yeah, I'm getting that on Mountain Lion as well.

Terms Privacy Security Status Help You can't perform that action at this time. The problem has been solved by titanous in fixing the gnu radio fork. I have found some hints searching the net with this error: Fatal Python error: Interpreter not initialized (version mismatch?) Looks like i'm not the only one to have this problem Thanks, Top nocturnal Re: Interpreter not initialized (version mismatch?) Quote Postby nocturnal » Sun May 08, 2011 1:12 pm I noticed that I was installing py26 packages, and someone on IRC pointed

It appears to compile just fine (I'm using the distutils setup.py to compile it), but when I import it in my Python script, it says "Fatal Error: Interpreter not initialized (version Look at all those library paths in there. up vote 6 down vote favorite 1 I'm now on my third full day this week of trying to get OpenCV to work with Python. (I have been trying on and Already have an account?

Thanks, Freddie sbfreddie closed this Aug 18, 2012 rfb commented Aug 30, 2012 I'm seeing the same version mismatch. $ gnuradio-companion Fatal Python error: Interpreter not initialized (version mismatch?) [1] 59514 check my blog Why is absolute zero unattainable? My thanks in advance to any information you can give me regarding this, because I really loved Settlers and I would love to try this game. sbfreddie commented Aug 16, 2012 Not a dumb question, a dumb person (me).

Reload to refresh your session. Please give further details. Terms Privacy Security Status Help You can't perform that action at this time. this content I have never seen this command before.

Would you please gist the output of brew update brew doctor brew --config brew list set And we'll see if anything looks odd. There brew update, brew doctor and hopefully brew install python samueljohn was assigned Mar 21, 2013 XL64 commented Mar 21, 2013 You solved my problem ! Python code by itself doesn't break this way (yeah!).

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

My ruby version is : ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin11.0], in /usr/bin/ruby which is a link to ../../System/Library/Frameworks/Ruby.framework/Versions/Current/usr/bin/ruby Have a nice day, thanks for your time, XL. When it does that, give us the url of the page that's created. Try to remove /usr/local/lib/python2.7 completely. No guarantees that it will work though, I've been having trouble getting it running on Mountain Lion with the latest Xcode (different python crash).

You signed out in another tab or window. Sign in. This is what is happening here, if you view the full compiler output for OpenCV it actually linked itself against 2.6 and will be unusable in your custom 2.7. http://bashprofile.net/fatal-python/fatal-python-error-deallocating-none-urlgrabber.html Also, I don't seem to be able to create new modules from scratch.

XL64 commented Mar 11, 2013 Hello, I don't think i'm in a virtualenv, didn't do anything for that as far as I know. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 21 Star 98 Fork 94 titanous/homebrew-gnuradio Code Issues 33 Pull requests 2 Projects For building python subversion bindings I had to do: sudo port install python_select sudo python_select python25 to select macports' python as the default python Since I noticed you were using Python 2.6, but it did not help with the error.

sbfreddie commented Aug 16, 2012 This is strange. It has been some time since I saw that one. I went back to the original installing first numpy, then Cheetah and lxml, then scipy by itself and then matplotlib by itself.